MailerLite Latency / Network issues
Incident Report for MailerLite
Resolved
This incident has been resolved, we will continue to monitor.
Posted 1 year ago. Jan 03, 2024 - 14:45 CET
Investigating
We are currently investigating reported latency issues.

Our team is fully aware of this issue and is working to resolve it as quickly as possible.
Posted 1 year ago. Jan 03, 2024 - 13:35 CET
This incident affected: MailerLite Email sending, MailerLite Links & tracking, MailerLite API & integrations, MailerLite Subscriber management, and MailerLite Automations.