click.mlsend.com links not working

Incident Report for MailerLite

Resolved

The underlying issue has been resolved. It may take some time to propagate the changes to all users.
Posted 3 years ago. Jan 27, 2022 - 14:07 CET

Identified

The issue has been identified and we are working with our domain registrar on fixing it.
Posted 3 years ago. Jan 27, 2022 - 13:29 CET
This incident affected: Classic (MailerLite Classic Links & tracking).