Problems while creating Email campaigns
Incident Report for MailerLite
Resolved
This incident has been resolved.
Posted Dec 25, 2021 - 20:50 EET
Investigating
We are currently investigating this issue.
Posted Dec 25, 2021 - 19:32 EET
This incident affected: MailerLite Classic APP.