Unavailability due to upstream issues

Incident Report for MailerLite

Resolved

The issue has been resolved.
Posted Dec 05, 2025 - 10:18 CET

Investigating

Our upstream provider, Cloudflare, is having a global outage, our team is closely monitoring the situation. Thank you for your patience.
Posted Dec 05, 2025 - 09:58 CET
This incident affected: MailerLite website, MailerLite Landing pages & websites, MailerLite Links & tracking, and MailerLite API & integrations.