Emails Delayed
Incident Report for MailerLite
Resolved
Emails are now processing as normal
Posted Apr 24, 2023 - 18:30 EEST
Investigating
We are currently investigating email sending delays
Posted Apr 24, 2023 - 18:04 EEST
This incident affected: MailerLite Email sending.