We are pleased to inform you that all services are fully restored. The issue was related to a third-party provider and we have successfully resolved it. Our team continues to monitor the situation to ensure everything remains stable.
Thank you for your patience and understanding.
Posted 10 days ago. Mar 07, 2025 - 16:11 CET
Update
We are currently experiencing an outage. Our engineers are actively working to restore service as quickly as possible. Subscribe to updates to stay up-to-date.
Posted 10 days ago. Mar 07, 2025 - 15:22 CET
Investigating
We are currently experiencing a major outage. We are actively working to restore service as quickly as possible.
Posted 10 days ago. Mar 07, 2025 - 15:20 CET
This incident affected: MailerLite Email sending, MailerLite Landing pages & websites, MailerLite Links & tracking, MailerLite API & integrations, MailerLite Subscriber management, and MailerLite Automations.