Delays in stats and import processing
Incident Report for MailerLite
Resolved
This incident has been resolved.
Posted Dec 07, 2023 - 11:58 CET
Investigating
We have identified a delay in the processing of statistics and imports, which may result in a temporary slowdown in backlog processing. Our team is fully aware of this issue and is working to resolve it as quickly as possible.
Posted Dec 07, 2023 - 11:11 CET