Email sending delays
Incident Report for MailerLite
Resolved
Email campaigns that been delayed have been sent or being delivered.
Posted Jun 19, 2020 - 13:51 EEST
Investigating
We are currently experiencing sending delay for some email campaigns. We apologize for the inconvenience. We will be sharing further updates here.
Posted Jun 19, 2020 - 12:08 EEST
This incident affected: MailerLite Classic Email sending.