Sendings Delayed

Incident Report for MailerLite

Resolved

This incident has been resolved. All sending delays have been cleared, and campaign sending performance has returned to normal.

We appreciate your patience and understanding while we worked to address this issue.
Posted Jul 15, 2025 - 15:40 CEST

Monitoring

The backlog is gradually clearing. While there might still be brief delays for some campaigns, we expect this to be fully resolved within the next 10-15 minutes.

Thanks for your patience!
Posted Jul 15, 2025 - 15:24 CEST

Identified

We're currently investigating an issue that may be causing delays in sending campaigns. You might experience degraded performance when trying to send your campaigns at this time.

We understand this can be frustrating and we're working hard to resolve it as quickly as possible. We'll provide an update as soon as we have more information.
Posted Jul 15, 2025 - 14:55 CEST
This incident affected: MailerLite Email sending.