Opens Delayed
Incident Report for MailerLite
Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 17:28 CEST
Investigating
We are currently investigating a delay in open stats.

We appreciate your understanding and patience during this time.

Thank you for your continued trust in our services.
Posted Aug 18, 2023 - 14:23 CEST
This incident affected: MailerLite Links & tracking.