MailerLite

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Degraded Performance
Resolved·Degraded performance

This incident has been resolved. All systems are back to normal operations. We apologize for any inconvenience caused and appreciate your patience.

Tue, Feb 24, 2026, 04:19 PM
(3 months ago)
·
Affected components
Feb 24, 2026, 04:07 PM
04:19 PM
MailerLite Subscriber management
MailerLite Automations
Updates

Resolved

This incident has been resolved. All systems are back to normal operations. We apologize for any inconvenience caused and appreciate your patience.

Tue, Feb 24, 2026, 04:19 PM

Monitoring

We have deployed a fix and are seeing signs of recovery across all affected services. We are continuing to monitor the situation closely to ensure stability returns to normal levels.

Tue, Feb 24, 2026, 04:12 PM

Identified

We have identified the cause of the performance degradation affecting MailerLite

A fix is currently being implemented. We will provide another update once the mitigation is underway.

Tue, Feb 24, 2026, 03:59 PM(13 minutes earlier)

Investigating

We’re investigating an issue causing degraded performance in the MailerLite app. Some users may experience latency. We are working to restore normal operation.

Tue, Feb 24, 2026, 03:40 PM(19 minutes earlier)